gulpの「gulp-gh-pages」のエラーを解決した「gulp-gh-pages-will」ってやつがあった

gulpの「gulp-gh-pages」がエラー吐くようになったので↓
gulpの「gulp-gh-pages」がエラー履くようになったときの対応 | 技術は生もの
で解決したんですが、npmでパッケージインストールするたびに似たようなことやらないといけなくて面倒なので追加調査しました。
原因は、上記記事にあるのですが、コレくらいならプルリク出してみようかと思ったら、フォークして解決したものを公開してくれてました。
さすがOSS!

gulp-gh-pages-will - npm
gulp-gh-pagesをこちらのgulp-gh-pages-willに置き換えましょう。
READMEが雑ですが、、、
「gulp-gh-pages」ってなっているところを「gulp-gh-pages-will」に書き換えてください。

  • package.json
  • gulpfile.js など

追記。。。
READMEはプルリク出てるんですがマージされてない。。
コレくらいペロッとマージしといてほしいなぁ